31st December Maintenance Window


Further to the above, while submitting confirmations statements and some of the other new schemas they fail most of the time (at least 9 in 10 fail) this will not be sustainable once the working week starts.

However, the change of accounting date new schema hasn’t worked at all today from hundreds (maybe thousands now) of attempts, this one is even more pressing as they can be much more date critical, someone submitting a change to their Accounting Ref date today could be rejected tomorrow as the date could have then gone for extending.


An update would be much appreciated, especially on change of accounting reference date, confirmation statements and company data.


Also another issue with the DataCheck it does not seem to bring back the correct CompanyIndentification, it still seems to bring back the PreBrexit CompanyIdentication


Morning all,

I will have these issues looked into as soon as possible.

Thank you.


Hi Simon,
Can you confirm which Incorporation Schema should be the live version. As we were expecting 3.3 to go live for BREXIT . On the schema page 3.5 seems to be live which had a release date of April for rhe Memorandum changes.

Many Thanks


It is 3.3 Mark (or 3.5 if you are doing the datamem variant).

Is this definitely still failing this morning please?


Hi Simon,

There are submissions still failing today. They seem to fail at a similar rate to how often the schema page gets an error (Companies House XML Gateway Input - Schema Status). If you get an intermittent error opening that page, then we are getting an error intermittently back from the gateway for that schema. So currently:

  • Company data is working almost all the time now (since Saturday) .
  • Confirmation Statements mostly return an error.
  • Change of accounting reference date started working at the weekend, and our submissions went through, we haven’t seen another one be requested in our software yet, but the schema page mostly returns without error now.
  • Incorporations are 50/50 (at least in the 3.3 schema), which as mark mentions, was enabled and deprecated on the 1st Jan according to the schema page. UPDATE - sorry I see that the 3.3 and 3.5 are both valid until april, so while this looks strange on the schema page, to release and deprecate on the same day, it’s correct.

As the confirmation statements start to get submitted today this will start to become a real issue, any updates you can give us would help massively so that we can make informed decisions about what we might need to do.


Morning all,
We are experiencing the same issues with the confirmation statement submissions.

Fatal error encountered during schema scan line 36 column 263

The public schema is 404’ing which I suspect is the cause if not related!

Thanks Ben, appeciated.


The 404 error may well be connected Arthur.


Hi Simon,

Looks like both the CS and Incorp are now working. We’ll monitor and let you know if that changes but looking much better now.


Thanks Ben,

We are confident that all the issues are now sorted.

Apologies to all and thank you for your patience.


Hi Simon,

can you please advise on pull service errors we’re still getting from the very moment of transition (from the 1st pull request done on Jan 1st 2021). Basically we’re getting following err from XML gateway:

    <Text>XML failed schema validation: Invalid XML: Type not found in http://xmlgw.companieshouse.gov.uk:CompanyNumberString  line 37 column 83</Text>

Here is full request body we’ve used for a few years with no problems before that (sensitive info removed) :

<GovTalkMessage xmlns="http://www.govtalk.gov.uk/CM/envelope" xmlns:dsig="http://www.w3.org/2000/09/xmldsig#" xmlns:gt="http://www.govtalk.gov.uk/schemas/govtalk/core" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.govtalk.gov.uk/CM/envelope http://xmlgw.companieshouse.gov.uk/v2-1/schema/Egov_ch-v2-0.xsd">
        <GetSubmissionStatus xmlns="http://xmlgw.companieshouse.gov.uk" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlgw.companieshouse.gov.uk http://xmlgw.companieshouse.gov.uk/v1-0/schema/forms/GetSubmissionStatus-v2-9.xsd">

Same for

<GetSubmissionStatus xmlns="http://xmlgw.companieshouse.gov.uk" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlgw.companieshouse.gov.uk http://xmlgw.companieshouse.gov.uk/v2-1/schema/forms/GetSubmissionStatus-v2-9.xsd">



Can you post the submission data that led to this GetSubmissionStatus request to snicholas@companieshouse.gov.uk please.


We’re seeing the same thing.
After a bit of investigation, it looks like v2.9 of the GetSubmissionStatus schema is referencing a XML type of CompanyNumberString, the schema itself is pulling in baseTypes-v3.4.xsd

The version of baseTypes-v3.4.xsd on the server doesn’t include a definition of CompanyNumberString , however a version I have previously downloaded on the 20th May 2019 did include a definition for it.

So it looks like baseTypes-v3.4 has been subsequently changed and is breaking the schema validation. I do notice that a baseTypes-v3.5.xsd had a go live of 1/1/21 and does include the definition.

Hello Laura - thank you.

We are looking into this.


Hi all,

We believe we have solved this now - is there anybody that can check that this is the case please?

Many thanks

Hi Simon,

I’ve tried again with my demo data and am no longer getting the rejection so seems good for me!

We’ll of course continue to monitor for any further customer reports of the issue and will let you know if anything comes up.

Do those that got the rejection need to resubmit their accounts?


Thank you so much Sue, and also for your email.

Yes, unfortunately, they will need to resubmit.


1 Like

Hi Simon,

confirm problem with GetSubmissionStatus resolved


Thank you for that IR!