Companies House "XML Gateway Search" Customer update

Companies House is always looking to improve on and develop our services. We have recently increased our API suite and we now provide a number of new free APIs for company search information which can be found in our Developer documentation Developer Hub Home (

As a result, we are contacting you to ask do you still need your XML Gateway search account?

The Developer’s API suite offers a range of products for you to get the best from the information we hold. Including alphabetical and same as name searches on the Public Data API, and access to real time data changes from the Streaming APIs. More information on these can be found on our API specifications page: Specifications list (

Alphabetical search API - Companies House Public Data API: Search for a company (

Name availability checker (same as) Companies House Public Data API: Search companies ( - for details see the Query parameter restrictions

If you no longer require your XML Account and would like to close it, please email and quote your account number.

If you wish to maintain your account, we would like to understand why and invite you to take part in our user research by XML Gateway search survey


You have a problem with the certificate / ssl settings on


I rarely see this, and nobody else appears to be having the same issue at the moment.

Can i ask what version of the SSL certificate you are using please?


Not sure what you mean by what certificate I am using, all I did was copy the above quoted url then pasted it into chrome. It does not matter whether I prepend it with https, I still get the same error and cannot proceed to browse.

Try these:


Both of the links are OK to browse to.
PS: Tried resetting HSTS in chrome settings but still no success with the original url.

It may be the way this forum pasted the information - it was from an email I sent to all XML Gateway Search customers.


I think it is more to do with the settings (relating to the certificate) you may have had previously set for the site. The error refers to the common name of the certificate - and you probably had your web-server pin that certificate. So it looks this will affect just those people that visited your site when the culprit certificate was up.

Thanks for your input.