Timeout sending multiple large attachments

Hi there,

Recently we had a client that received error 504: Gateway Time-out sending an IN01.

In that instance they had a large Memorandum attachment and they were able to reduce it in size (less than 2MB) to allow it to be sent but since then I am investigating what would happen if someone needed to send two or three attachments (e.g. Memorandum ‘and’ Supporting information regarding existing or sensitive name) where each document is approx 2MB in size.

It seems that during the send process at 60 seconds we receive back the 504: Gateway Time-out.

I have tried this on two machines on different networks (and I can reduce the timeouts in Winhttp below 60 seconds but increasing beyond 60 seconds makes no difference) it’s always around the 60 seconds mark - so I am wondering please…

  • Is this 60 second timeout a limitation imposed by the Companies House servers?
  • Is there anyway to allow users to submit 2 or three large (i.e. 2MB) attachments on the IN01 if needed?

Many thanks,

Good morning Alex,

I will get back to you.


Sorry Alex,

I am still trying to track down an analyst at the moment.

I would remind you however that “Memorandum of Association” documents can no longer be attached - we create this internally now and create the public record image ourselves.

As regards attachments in general though, our Specification states as follows:

Companies House can accept Company data as detailed within this Technical Interface
Specification within certain size/system limits. These limits are detailed below:
 The total size of the message can be no more than 10.0 mbytes for non-account
 The total Base64 encoded size of any individual data element must be a maximum
of 1.2 million characters
 Portable document Format (PDF) copies of deeds for the registration of charges
can be a maximum of 10.0 mbytes
If any of the supporting data or Articles are supplied these form part
of the total message size of 10.0 mbytes.


What was the name of the company by the way, and when did you try and file it?


Hi Simon,

For my “testing” on this the company is

Test UK Incorporation Limited

I tried to send it on the 5th June 2023 - during the day at various times but I have sent it again just now (09:07am 7th June 2023) and got the 504: Gateway Time-out

However please note I sent this company a number of times as I was experimenting with different file sizes and one or two will have gone through ok (when it didn’t time out with smaller attachment sizes) - on other occasions it got 504: Gateway Time-out.

Also please note regarding the size limits you mention on the last reply, my colleague Ferenc emailed you a while back (17 April 2023) about file sizes and it seems the max per attachment is 2MB (before it is is base 64 encoded). If the file it greater than this then your servers return the error PDF File size over 2mb

Many Thanks,

Thanks Alex - can you just confirm you are not trying to attach a “Memorandum of Association” document? I will continue to look into this with colleagues, but regret that it will be next week before I can come back to you again.


Thanks Simon,

No problem I appreciate your looking into this for me.

The three documents I am trying to attach are

  1. Articles of association (ARTS) e.g. such as if a company is using ‘amended’ or ‘bespoke’ articles
  2. Sensitive Word Supporting Information (SUPPNAMEAUTH)
  3. Same Name Supporting Information (SUPPEXISTNAME)

Thanks again,

Thanks for the confirmation Alex.


Hi Alex,

Apologies for continued delay in coming back to you on this - yes I recall my response to Ferenc. In the absence of ultimate clarification, I think it is best to assume the max per attachment to be 2MB (before it is is base 64 encoded).

This is the best advice I can supply at the moment - with all the resource dedicated to the legislation currently going through Parliament, its going to be difficult for me to find somebody able to test this in detail.


Hi Simon,

Thanks for your reply re confirmation of the upload file size.

Appreciate it’s a busy time for you guys so not urgent at all but if you get the chance at some point it would be good to know whether there is a “timeout” imposed by Companies House when sending messages to the xml servers?

i.e. as mentioned I seem to be unable to increase the timeout when sending messages beyond one minute before I receive

504: Gateway Time-out.

Not urgent though - I don’t think anyone other than our initial client has had the Gateway timeout issue. If customers do get it, for the time being, we will tell them to try and reduce their pdf attachment file sizes if they have two or more attachments at around the max file size.

Many thanks again,