Which URL should I be testing against for the 30 June 2016 release?

I am currently getting this response -

Invalid schema URI supplied [http://xmlgw.companieshouse.gov.uk http://xmlalpha.companieshouse.gov.uk/v1-0/schema/forms/CompanyIncorporation-v3-0-alpha3.xsd]


Sorry you are having trouble, but the INC schema URI is correct and the baseTypes it uses are correct so it should be fine. I will get a tester to try it first thing tomorrow but if you want to send us your xml you are using, just in case there are problems.

I have emailed the XML we are using to Simon. I look forward to hearing from you.


We tried running through your xml against alpha, our test kit removes the gov talk headers but the actual incorporation submission hit Alpha fine without errors. Can you check you gov talk headers but other than that what you are submitting looks fine.

Thanks for replying to my forum post. I have tested the theory that our gov talk header was incorrect but I don’t think this is the issue.

I have created two version of xml which I have just emailed to you. One is using schema 2-8 and the other is 3-0-alpha. Both schemas use identical gov talk headers.

The xml for 2-8 validates and creates no errors but 3-0-alpha still generates this error –
Invalid schema URI supplied [http://xmlgw.companieshouse.gov.uk http://xmlalpha.companieshouse.gov.uk/v1-0/schema/forms/CompanyIncorporation-v3-0-alpha3.xsd]

Please can you take another look at this issue please.

Many thanks.

No probs will look first thing Monday

I’m having the same issue: Invalid schema URI supplied: …/v1-0/schema/forms/CompanyIncorporation-v3-0-alpha3.xsd
Using govTalk: …/v1-1/schema/Egov_ch-v2-0.xsd
and formsubmission: …/v2-1/schema/forms/FormSubmission-v2-9.xsd

This is very weird as we submitted the xml provided and submitted fine and there are other testing against alpha. We will continue to investigate, could you send the xml you used to Simon Nicholas snicholas@companieshouse.gov.uk
thanks, will get back to you tomorrow with what we find out

I don’t know how you submitted the xml I provided. I havn’t supplied it yet. I’ll send to Simon N now

If you are submitting the request To: https://xmlgw.companieshouse.gov.uk/v1-0/xmlgw/Gateway then try changing it To: https://xmlalpha.companieshouse.gov.uk/v1-0/xmlgw/Gateway

change to xmlalpha for incorporation schema only? (as I am testing incorporations). Or must we also change for Egov and FormSubmission?

Yes the Incorporation schema only

When I submit to xmlalpha I get this response - “Authorisation Failure”

Do I need another test account for this server/end point?

I had the same problem. Get them to copy your test account from live to alpha.

Thanks for your help. I will ask them to do this.

I’m still getting the same error but substitute xmlalpha for xmlgw.
Before I request that my test account is copied to alpha, this is the incorporation soc header - can you spot what is wrong? Should the first http://xmlgw.companieshouse.gov.uk change to xmlalpha also?


Can you copy my test credentials over to the alpha gateway please? You should have them in the XML Simon forwarded to you a few days ago.

I have emailed Simon and the generic xml email address but both are not in the office for a few days.


This is my CompanyIncorporation tag. The only place to change xmlgw to xmlalpha is in the xsi:schemaLocation attribute.

CompanyIncorporation xmlns=“http://xmlgw.companieshouse.gov.uk” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” xsi:schemaLocation=“http://xmlgw.companieshouse.gov.uk http://xmlalpha.companieshouse.gov.uk/v1-0/schema/forms/CompanyIncorporation-v3-0-alpha3.xsd

Thanks. It still isn’t working so I suppose I need my credentials copying over to alpha. Simon N has them I think.

Are you getting the “Authorisation Failure” response now? If so then copying your account to alpha will fix it.