XML error: Fatal error encountered during schema scan


I have been trying to send an XML request to the test XML gateway to test company formation. When I send my XML data over, the response is XML failed schema validation: XML error: Fatal error encountered during schema scan line 16 column 155. I am unsure where line 16 is referring to, as I reformatted my XML request to all be on a single line, and yet the same error is returned. What is the XML Gateway referring to by line 16?

Any help would be greatly appreciated.

Hi Dan,

I would suggest you running your file through a commercial application called XML spy as this will format it for you.

Please let me know if this works for you.


Could also open the file as is using Notepadd++ where you can look for line number and position (displayed in the status bar)

As I said in my original post, it does not matter how the file is formatted when I send it, the error always says line 16 column 155. It gives me that line number even if I put all the XML data onto one line.

Try opening the file in a browser - does that still NOT show line numbers?
Saying that, I think you have a syntax error (or a character that’s not utf8 encoded) in your file, in which case, format the file using an xml formatter and if that does not highlight the error re-upload the (newly formatted) file and it should give you the ‘proper’ line number. Last but not least, upload the file here.


XML Spy isn’t the best solution for us. firstly because of the high cost to obtain a license, but also because the company I work for does not use Windows. I have run my XML file through the syntax checker in the Eclipse IDE. After a couple of changes, it lists no syntax errors when comparing my file to the schemas provided by CH. However when I send this fixed file through the XML Gateway as before, I still get line 16 column 155 as the source of an error. In my file, line 16 contains the hashed authentication value as seen here: (I have replaced my hashed auth value with Xs for security, but it still contains 32 characters). <Value>XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX</Value>

If there was a problem in the element on line 16, surely I would get an authentication error returned by the gateway instead?

Hi Dan,

Can you please post your test submission data and test presenter ID to xml@companieshouse.gov.uk and I will take a look at it.


hi @dan_perry @snicholas how was this issue resolved. I’m getting the exact issue "line 16 column 155 " in the error response… I’m simply testing with postman using thee sample request here . http://xmlgw.companieshouse.gov.uk/examples/companydetails_req.xml. I put in my test credentials .

I have just sent you an email.

Best if we set up a new test account for you, as the one you have is very old, and a lot has changed since yours was opened.